BUG - Zoho broke the API (Again) -- can't sort by modified time
Zoho obviously pushed a new build to production last night, because we woke up this morning with our integration completely broken and our business crippled. Thanks again, Zoho. This at least the fourth time something like this has happened. I cringe at the thought that you're going to push code without telling anyone, and it could cause something that's been working fine for months to stop working completely.
Problem
This used to work fine:
Now, it gives this error:
<response uri =" /crm/private/xml/Leads/getRecords " >
<error>
<code>
4401
</code>
<message>
Unable to populate data, please check if mandatory value is entered correctly.
</message>
</error>
</response>
Cause
Through trial and error, I discovered that the problem is caused by this: &sortColumnString=Modified%20Time
Interestingly, if I change it to some invalid random string, like "&sortColumnString=foobar", it doesn't give any error, it just ignores it. I've also tried different variations, like "Modified_Time" and "ModifiedTime", but these are just ignored. Using "Modified Time" causes the whole thing to break. And the error is strange too -- it says "unable to populate data" -- but this is a READ operation, and 4401 is usually for a write operation...
Expected Behavior
When performing a getRecords operation through the API, including "&sortColumnString=Modified%20Time" in the url should not error, and it should cause the list of records returned to be sorted in order of modified time.