Issues:
Unable to start or access the application after upgrading to 4600 or 4610 version.
Case 1:
The application fails to start.
Case 2:
The application was started successfully, but couldn't access the UI
Root cause:
A few files were missing in the instance which is responsible for accessing/starting the application successfully
This case occurs only in a windows environment.
Case 1 error trace:
Trying to start PostgresSQL server failed
INFO | jvm 1 Problem while Starting
Trace to be checked on the wrapper log under <Analytics home>\logs\wrapper
Case 2 error trace:
Caused by: java.io.IOException: Keystore was tampered with, or password was incorrect
at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:780)
at sun.security.provider.JavaKeyStore$JKS.engineLoad(JavaKeyStore.java:56)
at sun.security.provider.KeyStoreDelegator.engineLoad(KeyStoreDelegator.java:225)
... 25 more
Caused by: java.security.UnrecoverableKeyException: Password verification failed
at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:778)
... 35 more
Trace to be checked on the serverout_(today's date) log under <Analytics home>\logs\serverout_(today's date)
Note: Where (today's date) to be denoted of server's current date right next to the file name serverout_.
Example: serverout_2021-04-27.txt
Solutions:
Case 1:
Step 1: Log on to the installed server of Zoho Analytics on-premise
Step 2: Navigate to the below path
<Analytics home>\conf\wrapper.conf
Step 3: Open the file and please add the below entry if it is missing at the end of the line.
set.PATH=../lib;%PATH%
Step 4: Save the file and start the Zoho Analytics on-premise service.
Case 2:
Step 1: Log on to the installed server of Zoho Analytics on-premise.
Step 2: Navigate to the below path
<Analytics home>\conf\server.xml
Step 3: Open the file and please add the below parameter right before the 'scheme' param inside the "<<!-- Define a non-SSL Coyote ...." title tag as shown in the below picture.
protocol="com.adventnet.zoho.db.onpremise.session.KeystorePassDecryptor"
Step 4: Save the file and restart the Zoho Analytics on-premise service