Unable to use Zoho mail SMTP server in Zoho Analytics Onpremise

Unable to use Zoho mail SMTP server in Zoho Analytics Onpremise

Issue:
Unable to configure zoho mail server in ZAOP



Cause:
Zoho Mail has now applied certificates


  1. [15:58:32:717]|[03-31-2021]|[SYSERR]|[INFO]|[55]: org.apache.commons.mail.EmailException: Sending the email to the following server failed : smtp.zoho.com:587
  2. at org.apache.commons.mail.Email.sendMimeMessage(Email.java:1421)
  3. at org.apache.commons.mail.Email.send(Email.java:1448)
  4. at com.adventnet.zoho.db.onpremise.server.mail.OPMailUtil.sendTestMail(OPMailUtil.java:738)
  5. ......
  6. at java.lang.Thread.run(Thread.java:745)
  7. Caused by: javax.mail.MessagingException: Could not convert socket to TLS;
  8.   nested exception is:
  9. javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
  10. at com.sun.mail.smtp.SMTPTransport.startTLS(SMTPTransport.java:2000)
  11. at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:709)
  12. Error traces

Fix:
Below is the fix from the developers.

1.      Stop the Zoho Analytics Onpremise service.
2.      Download the fix and move it under <Zoho Home>/Analytics/fixes (Create the folder if not present)
3.      Start the service.

The provided patch is applicable for both versions 4600 and 4610. 

Use the below setting,
SMTP Server - smtp.zoho.com
SMTP Port - 587
Email Id/UserName - Zoho Email Id
Password - Zoho Password
Select TLS