Macデバイスにおいてパスキーによるサインインが失敗した

Macデバイスにおいてパスキーによるサインインが失敗した

原因

Macデバイスでパスキーを使用してZohoにサインインしようとしたときに、パスキーによるサインインが失敗した旨のエラーが発生する場合があります。この問題は、次のいずれかの原因で発生した可能性があります。

利用中のブラウザーがサポートされていない
サインインに使用しているSafari のブラウザーが、パスキーに対応していない可能性があります。パスキーはバージョン16以上でサポートされています。

アカウント(Apple ID)が一致していない
Macデバイスのサインインに使用したアカウント(Apple ID)が、パスキーを同期しているアカウントと異なっている可能性があります。たとえば、「kawane@zylker.com」というメールアドレスのApple IDを使用してサインインしているiPhoneで、パスキーを生成したとします。生成されたパスキーは、「kawane@zylker.com」のApple IDと同期されます。その後、「yokohama@zylker.com」という異なるメールアドレスのApple IDでサインインしているMacから、Zohoにサインインしようとしたとします。しかし、「kawane@zylker.com」のメールアドレスに対応するZohoアカウントのパスキーは「yokohama@zylker.com」のApple IDとは同期されていないため、サインインできず、エラーが表示されます。

キーチェーンが無効になっている
パスキーはiCloudのキーチェーンに保存されます。Macでキーチェーンが無効になっている場合、エラーが表示されます。

解決方法

エラーを解決するには、以下の方法を実施してください。
  1. Safariブラウザーを最新のバージョンに更新する。
  1. パスキーが同期されているのと同じApple IDを使用してMacにサインインする。
  1. MacでiCloudのキーチェーンを有効にする。手順は以下のとおりです。
    1. macOSのバージョンがMonterey以下の場合:
      1. [システム環境設定]を開きます。
      2. [Apple ID]をクリックし、画面左側のメニューの[iCloud] をクリックします。
      3. [キーチェーン]を選択します。
    2. macOSのバージョンがVenturaの場合:
      1. [システム環境設定]を開きます。
      2. 画面左側のメニューに表示されているアカウント名をクリックします。
      3. [iCloud]をクリックし、[パスワードとキーチェーン]を有効にします。
なお、上記の操作を行わない場合でも、従来のサインイン方法でアカウントにサインインすることは可能です。