以前のルールに、重複している条件があります。同様の条件が、以前のルールで定義されています。続けるには、条件を変更してください。
説明
条件による割り当て機能を使用して、ユーザーにアプリケーションを割り当てる際に、同じユーザーを対象とするルールを複数追加しようとすると、このエラーが発生します。
原因
条件による割り当て機能を使用してユーザーに役割を割り当てる際に、同じユーザーを対象とするルールを複数設定しようとした可能性があります。このような設定はできません。同一のユーザーに対して、2つの異なる役割を割り当てることはできないためです。
例を見てみましょう。Zylker社の管理者が、「Zoho Assist」をユーザーに割り当てるとします。「部門A」のユーザーに「管理者」の役割を割り当てる条件を設定しました。さらに、もう1件のルールを作成します。「部門B」のユーザーに「技術者」の役割を割り当てる条件を設定します。そこで、誤って最初のルールの対象ユーザーの条件を、そのまま2番目のルールに複製しました。その結果、同じユーザーを対象とするルールが2つ設定され、1人のユーザーに対して異なる役割が割り当てられる不適切な設定になってしまいました。
[割り当てる]をクリックすると、上記のエラーメッセージが表示されます。
解決方法
- 条件設定では、対象の項目と条件の種類を選択し、条件に合致するかどうかを判定するための値を入力します。これらの項目が正しく設定されているかどうかをご確認ください。たとえば、条件[User.User Type](ユーザーの種類)の例を見てみましょう。この項目に対して設定可能な条件の種類は、[が次の値と等しい]および[が次の値と等しくない]です。設定可能な値は、[Confirmed](認証済み)と[External](外部)です。最初のルールでは、「[User.User Type](ユーザーの種類)[が次の値と等しい][Confirmed](認証済み)」と設定します。2番目のルールでは、「[User.User Type](ユーザーの種類)[が次の値と等しくない][Confirmed](認証済み)」と設定します。ただし、ここで最初のルールの対象ユーザーの条件設定を、誤って複製してしまいました。つまり、「[User.User Type](ユーザーの種類)[が次の値と等しい][Confirmed](認証済み)」と設定して、アプリケーションの割り当てを設定しました。これにより、上記のエラーメッセージが表示されました。このような場合、項目、条件の種類、値の項目が正しく入力されていることをご確認ください。
- 最初のルールで対象にしたユーザーを2番目のルールでは対象から除外する場合、2番目のルールの対象ユーザーについて条件を個別に指定する代わりに、[その他のユーザー]を選択することで簡単に設定できます。たとえば、[User.Created time](ユーザーの作成日)の例を見てみましょう。使用可能な条件の種類は、[が次の値と等しい]、[が次の値と等しくない]、[が次の後]、[が次の前]です。入力する値は、「dd/mm/yyyy」形式の日付です。最初のルールでは、「[User.Created time](ユーザーの作成日)[が次の値と等しい][01/01/2000]」と設定しました。2番目のルールでは、「[User.Created time](ユーザーの作成日)[が次の値と等しくない][01/01/2000]」と設定することもできますが、2番目のルールでは最初のルールの対象データ以外を対象にするため、代わりに[その他のユーザー]を選択することで簡単に設定できます。