説明
カスタム項目(独自の項目)の無効化や削除を行おうとすると、カスタム項目がアプリのシングルサインオンの設定で名前IDを参照するための項目として使用されている旨のエラーメッセージが表示される場合があります。
原因
以上のような場合、カスタム項目を無効にしたり、削除したりできないのは、対象のカスタム項目が、シングルサインオン(SSO)による認証において
名前ID
(ユーザーを識別するための情報)の値に使用されているためです。通常、連携アプリへのシングルサインオン(SSO)では、ユーザーを識別するために名前IDが使用されます。初期設定では、メインのメールアドレスが名前IDとして使用されます。ただし、名前IDには、ユーザー情報に関する別の値を使用することも可能です。
関連情報:名前IDの設定
名前IDにカスタム項目を使用している場合、対象のカスタム項目が無効化されたり、削除されたりすると、名前IDが連携アプリに送信されなくなり、シングルサインオン(SSO)による認証処理は失敗します。そのため、カスタム項目は、名前IDに使用されている限り、無効化したり削除したりすることはできません。無効化/削除を行うには、まず、名前IDの設定からカスタム項目を削除する必要があります。
解決方法
名前IDに使用されているカスタム項目の無効化/削除の手順:
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Zoho One
にサインインします。
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画面左側のメニューで
[Directory]
をクリックします。
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画面左側のメニューで
[ユーザー]
をクリックし、画面上部に表示されている
[項目の管理]
をクリックします。
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対象のカスタム項目にカーソルを重ねて、
(その他)アイコンをクリックし、
[無効にする]
または
[削除する]
を選択します。エラーメッセージと、このカスタム項目が名前IDに使用されている連携アプリの一覧が表示されます。
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表示された連携アプリの名前をメモします。
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画面左側のメニューで
[アプリケーション]
をクリックし、手順5でメモした連携アプリをクリックします。
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[シングルサインオン(SSO)]
タブに移動し、
[サービスプロバイダーの詳細]
をクリックします。
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認証情報の詳細
の欄で
[アプリケーションのユーザー名]
の項目に、カスタム項目または
[カスタム]
が設定されていないかどうかを確認します。
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カスタム項目が設定されている場合は、カスタム項目以外の設定に変更します。
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[カスタム]
が設定されている場合は、
[パターンの値]
を編集して、カスタム項目を使用しない設定に変更します。
メモ:上記の操作を行うと、アプリへのシングルサインオン(SSO)によるサインインが正常に実行されなくなる可能性があります。サービスを継続して利用できるようにするためにも、Zoho Oneや連携アプリの設定変更は慎重に行うようにしてください。
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対象のカスタム項目が名前IDに使用されている連携アプリ(手順5でメモしたアプリ)が複数ある場合は、アプリごとに手順6から手順8の操作を行い、すべてのアプリで名前IDの設定からカスタム項目を削除します。
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すべてのアプリで名前IDの設定からカスタム項目を削除したら、手順1から手順4によって、項目を無効化/削除できます。