WorkDrive server upgrade incident: Zoho Flow and Deluge user API calls affected in US DC (Issue fixed)

WorkDrive server upgrade incident: Zoho Flow and Deluge user API calls affected in US DC (Issue fixed)

Hello everyone,

We recently encountered an API call failure issue in the Zoho Flow and Deluge apps. The details of the issue are as follows:

About the Issue
  • The WorkDrive API and WorkDrive Integration tasks in Deluge returned error responses.
  • Zoho Flow tasks that were configured with WorkDrive actions failed.
Cause
The issue was caused by a bug introduced by the latest upgrade, when we attempted to modify the logic for auditing API actions.

Impacted users
  • Zoho Flow users who have configured WorkDrive actions in the Zoho Flow service in the US DC.
  • Zoho Deluge users who have used WorkDrive integration tasks or WorkDrive APIs using invokeURL task from any Zoho services in the US DC.
    Note: US DC refers to users whose accounts are mapped to the US data center.
Issue duration
July 18, 2023 04:54 AM PDT to July 18, 2023 11:57 PM PDT

Detection and resolution time
We detected the issue on July 18, 2023 at 5:20 PM PDT and successfully fixed it by July 18, 2023 at 11:57 PM PDT.

Root cause analysis

Nature of the issue
During one of our planned upgrades to our WorkDrive servers on July 18, 2023, an unintended bug was introduced, leading to API call failures when Zoho Flow attempted to communicate with WorkDrive. Similarly, Zoho Deluge's integration tasks and APIs faced issues, resulting in error responses. The root cause was traced back to our efforts to modify the logic for auditing API actions, particularly the auditing of API requests for actions like creating files or folders.

Impact
Only users who had their data stored in the US DC were affected by this issue, and they might have encountered unexpected behavior in API responses. It's important to note that, although some API actions returned failure statuses, some actions partially succeeded.

Resolution
Our development team worked promptly to resolve the bug, and we have released an immediate hotfix update to rectify the problem.

Preventive measures
We sincerely apologize for any inconvenience caused during this period. To prevent similar incidents in the future, we have implemented additional checks and balances in our upgrade procedures to ensure the stability and reliability of the system.

Thank you for your understanding. We remain committed to providing you with the best possible service. If you have any questions or concerns, please feel free to drop them in the comment section below.

      • Sticky Posts

      • Ask the Experts: Five-hour live Q&A session with Zoho WorkDrive product experts

        Hello all, We are excited to host the Ask the Experts session on July 18, 2024 between 2:00 PM – 7:00 PM IST. Whether you're just starting to use Zoho WorkDrive, or if you've been with us for a while, this session is an amazing opportunity to discuss
      • WorkDrive API Documentation

        WorkDrive provides users and developers an extensive set of APIs to help integrate functionalities of Zoho WorkDrive with other Zoho applications and third-party tools. We have published the official WorkDrive API Documentation page for all external users.
      • March 15, 2023: Zoho Docs is discontinued

        As of today (March 15, 2023) Zoho Docs is discontinued for all users. We would like to thank our customers for trusting us for so many years! Going forward, we're confident you'll enjoy using Zoho WorkDrive for all your advanced file management and collaboration
      • Support for auto-upgrade in TrueSync (for Windows)

        WorkDrive TrueSync app now supports auto-upgrading to the latest version for Windows OS. You must manually download and install the TrueSync app version 3.4.0 to avail this feature. Download the latest TrueSync app for Windows (version 3.4.0) Supported
      • Introducing Collections

        Create collection links to easily request any number of users to upload files to a particular folder. Once users upload their files, you will be able to view their submissions and manage their files effortlessly. Users don't need a WorkDrive account to