4600または4610へのアップグレード後にアプリケーションを起動またはアクセスできない問題

4600または4610へのアップグレード後にアプリケーションを起動またはアクセスできない問題

お知らせ:当社は、お客様により充実したサポート情報を迅速に提供するため、本ページのコンテンツは機械翻訳を用いて日本語に翻訳しています。正確かつ最新のサポート情報をご覧いただくには、本内容の英語版を参照してください。

問題:

バージョン4600または4610へのアップグレード後、アプリケーションを起動または利用できません。

ケース1:
アプリケーションを起動できません。

ケース2:
アプリケーションは正常に起動しましたが、UIにアクセスできません。

原因:

アプリケーションの正常な起動やアクセスに必要なファイルが、インスタンスにいくつか不足していました。

この問題は、Windows環境でのみ発生します。

ケース1のエラートレース:

Trying to start PostgresSQL server failed
INFO | jvm 1 Problem while Starting

<Analytics home>\logs\wrapperにあるwrapperログでトレースを確認します。

ケース2のエラートレース:
Caused by: java.io.IOException: Keystore was tampered with, or password was incorrect
at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:780)
at sun.security.provider.JavaKeyStore$JKS.engineLoad(JavaKeyStore.java:56)
at sun.security.provider.KeyStoreDelegator.engineLoad(KeyStoreDelegator.java:225)
... 25 more
Caused by: java.security.UnrecoverableKeyException: Password verification failed
at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:778)
... 35 more

serverout_(today's date) ログのトレースを、<Analytics home>\logs\serverout_(today's date)で確認します。

メモ:ここで、 (today's date)は、次のファイル名の直後に付加されるサーバーの現在の日付を示します。 ファイル名:serverout_
例:serverout_2021-04-27.txt

解決策:

ケース1:
手順1:Zoho Analytics On-Premiseがインストールされているサーバーにログインします。

手順2:以下のパスに移動します。

<Analytics home>\conf\wrapper.conf


手順3:ファイルを開き、末尾の行に以下の記述がない場合は追加します。

set.PATH=../lib;%PATH%




手順4:ファイルを保存し、Zoho Analytics On-Premiseサービスを起動します。

ケース2:
 
手順1:Zoho Analytics On-Premiseがインストールされているサーバーにログインします。

手順2:以下のパスに移動します。

<Analytics home>\conf\server.xml


手順3:ファイルを開き、下図のように、'scheme'パラメーターの直前('<<!-- Define a non-SSL Coyote ....'タイトルタグ内)に以下のパラメーターを追加します。

protocol='com.adventnet.zoho.db.onpremise.session.KeystorePassDecryptor'





手順4:ファイルを保存し、Zoho Analytics On-Premiseサービスを再起動します。