SalesIQでのAzure AI Translator連携方法

SalesIQでのAzure AI Translator連携方法

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Azure AI Translator は、リアルタイムでテキストやドキュメントを翻訳できるクラウドベースの翻訳サービスです。これを SalesIQ と連携すると、訪問者とのチャットをある言語から別の言語へリアルタイムで翻訳でき、オペレーターは世界中の訪問者を簡単にサポートできるようになります。この連携では 100 を超える言語の翻訳が可能になり、オペレーターはすべての地域の訪問者とリアルタイムでコミュニケーションを取ることができます。

Azure AI Translator 連携の設定

  1. SalesIQ のダッシュボードから、設定 > Integrations > Translate に移動し、Azure AI Translator を選択します。
  1. 右上の 追加する をクリックします。

  1. Let's 設定する セクションに Azure API token を追加できます。これは Azure ポータルで取得した翻訳サービスキーであり、連携に必須の入力項目です。Azure API トークンの取得方法
  2. 次に、リソースを作成した Region を入力します。リージョンの入力は、マルチサービス Translator リソース を使用する場合は必須で、シングルサービス Translator リソースを使用する場合は任意です。
  3. 有効にする をクリックして連携します。
  1. プライバシーに関する注意事項のポップアップが表示されます。内容を理解したことを示すためにチェックボックスをオンにし、承認する and 続ける をクリックします。

  1. これで Azure AI Translator 連携が有効になり、メッセージをリアルタイムで翻訳できるようになります。

Azure AI Translator の設定

Azure AI Translator 連携では、次の設定を利用できます。

Azure AI Translator への接続

ここでは、連携の設定時に入力した API トークンとリージョンを確認できます。API トークンやリージョンを更新したい場合は、ここで編集し、更新する をクリックして変更を保存します。

詳細設定

ここでは、チャットウィンドウの翻訳設定を行うことができます。

言語検出
訪問者メッセージの言語を自動検出するか、手動で検出するかを選択できます。
  1. Automatic - 訪問者の言語がオペレーターの言語と異なる場合、自動的に翻訳を促すメッセージが表示されます。
  2. Manual - オペレーターが手動で訪問者の言語を検出し、必要に応じてメッセージを翻訳できます。

チャットをリアルタイムで翻訳する

Azure AI Translator 連携が有効になると、オペレーターは外国語で送信された訪問者メッセージをリアルタイムで翻訳できるようになります。ここでの翻訳動作は、連携設定で選択した言語検出の設定に基づいて行われます。

自動検出を選択した場合

  1. 訪問者からチャットが受信されると、SalesIQ によって外国語が自動的に検出されます。
  2. 検出された言語が表示された Azure 翻訳バナーが、チャット画面の上部に表示されます。
  3. オペレーターは Translate をクリックしてチャットを翻訳するか、「x」をクリックして訪問者の言語のままチャットを続行できます。

  1. Translate をクリックすると、チャットは自動的に翻訳されます。

手動検出を選択した場合

  1. オペレーターが理解できない言語でメッセージを受信した場合、そのメッセージにカーソルを合わせて Translate をクリックすると、メッセージを翻訳できます。

  1. 検出された言語が表示された翻訳バナーが、チャット画面の上部に表示されます。

  1. Translate をクリックして、チャットを翻訳します。

チャット中の翻訳を停止する

  1. 訪問者の言語のままチャットを続行したい場合は、チャット中いつでも翻訳を停止できます。
  2. 翻訳を停止するには、翻訳バナー上の 停止する ボタンをクリックします。

  1. 再度翻訳を有効にしたい場合は、もう一度 Translate ボタンをクリックします。

元の内容のトランスクリプトを表示する

元のトランスクリプトを表示したい場合は、Azure 翻訳バナー上部に表示される二重矢印をクリックします。

メモ: Azure AI Translator 連携を有効にするには、ポータル設定で Zoho Translation が無効になっていることを確認してください。確認するには、設定 > Global 設定 > Operator Interface に移動し、Zoho Translation をオフにします。

Azure AI Translator サービス利用時のよくあるエラー

Issue
Cause

同じテキストが 2 回表示される
ある言語では同じ意味を持つ複数の単語が含まれる文があり、別の言語に翻訳した際に、同じ単語が 2 回繰り返されて表示される場合があります。
翻訳後に文字数が増加する
ある言語に変換した場合、文が長くなることがあります。
動的テキストの翻訳失敗
ロシア語、日本語、スペイン語など一部の言語に翻訳する際、スペイン語では動的テキストの翻訳に失敗する場合があります。
絵文字がサポートされない
中国語や日本語など一部の言語では、正しく翻訳されない場合があります。
スモールトークの翻訳失敗
アカウントの翻訳上限に達している可能性があります。
書式付きテキストの翻訳失敗
Translator 側の問題です。
一部の言語のよくある質問(FAQ)で、翻訳が継続的に失敗する。
Translator 側の問題です。

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