Integrating Azure AI Translator with SalesIQ

Integrating Azure AI Translator with SalesIQ

Azure AI Translator is a cloud-based translation service for real-time text and document translation. Integrating this with SalesIQ helps you translate visitor chats from one language to another in real-time and equips your operators to effortlessly support visitors worldwide. This integration allows translation of more than a hundred languages and enables operators to communicate with visitors from all regions in real-time. 

Setting up the Azure AI Translator integration

  1. From the SalesIQ dashboard, navigate to Settings > Integrations > Translate, and select Azure AI Translator.
  1. Click on Add at the top right.

  1. You can add the Azure API token in the Let's configure field. This is your translator service key from your Azure portal and a mandatory input for the integration. How to get my Azure API Token?
  2. Next, fill in the Region where your resource was created. The region input is mandatory for multi-service translator resource and optional when using a single-service translator resource.
  3. Click on Enable to integrate.
  1. The privacy concern disclaimer will pop-up. Enable the checkbox to signify that you have understood the concerns and then click on Accept and Proceed.

  1. Now, your Azure Al Translator integration will be enabled to translate messages in real-time.

Configuring Azure Al Translator

The following configurations are available for your Azure Al Translator integration.

Connect to Azure Al Translator

Here, you can view the API token and Region inputs provided for setting up the integration. If you wanted to update the API token and/or Region, you can do that here and then click Update to save the changes.

Advanced configurations

You can set up the chat window translation configurations here.

Language detection
You can choose whether you want the language of the visitor messages to be detected automatically or manually.
  1. Automatic - If the visitor's language differs from the operator's language, then a prompt appears automatically to translate the message.
  2. Manual - Operators can choose to manually detect the visitor's language and then translate the message, if required.

Translating chats in real-time

Once the Azure Al Translator integration is enabled, your operators will be able to translate visitor messages in foreign languages in real time. Here, the translation works based on the language detection configurations chosen in the integration settings.

If automatic detection is chosen

  1. Once the visitor's chat is received, the foreign language will be automatically detected by SalesIQ.
  2. The Azure translate banner will appear at the top of the chat with the detected language.
  3. Operators can click on Translate to get the chat translated or click on the “x” to continue chatting in the visitor's language.

  1. The chat will be translated automatically once Translate is clicked.

If manual detection is chosen

  1. When a message is received in a language that the operator is not familiar with, they can hover over the message and click on Translate to translate the message.

  1. The translate banner will appear at the top of the chat with the detected language.

  1. Click on Translate to get the chat translated.

Stop translation during chat

  1. You can stop the translation at any time during the chat if you want to continue the chat in the visitor's language.
  2. To stop translation, click on the Stop button on the Translate banner.

  1. In case you wanted to continue the translation, you can click on the Translate button again.

View the original transcript  

If you wish to view the Original Transcript, then click on the double arrow that appears at the top of the Azure translate banner.

Note: To get the Azure AI Translator integration activated, make sure that Zoho Translation is disabled in Portal Settings. To check this, navigate to Settings > Global settings > Operator Interface and turn off Zoho Translation.

Common errors while using Azure AI Translator service

Issue
Cause

Same text appears twice
Certain sentences of a language might have multiple words that convey the same meaning, but when translated to another language, the same word might be repeated twice.
Increase of letters after translations
Sentences might get longer when converting to a certain language.
Dynamic text failure
While translating to certain languages like Russian, Japanese, and Spanish, Spanish will fail to translate dynamic texts.
Emojis are not supported
Some languages like Chinese and Japanese might not be translated properly.
Failure in small talk translation
Could have reached the translation limit in your account.
Failure in formatted text translation
Translator based issue.
In FAQ for some of the languages, translation is failing continuously.
Translator based issue.

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