Zoho Payroll エラー処理と解決マニュアル 第2部

Zoho Payroll エラー処理と解決マニュアル 第2部

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この記事は、全2回シリーズのパート2で、ユーザーがZoho Payrollでよく発生するエラーを特定し、解決できるようにすることを目的としています。

まだパート1(よくあるエラー1〜12を解説)をお読みでない場合は、まずそちらからご覧ください。

Zoho Payroll エラー対応・解決マニュアル – パート1

このパート2では、以下を含む追加のエラーシナリオ(13〜25)を解説します。
  • Zoho People との連携同期エラー
  • 日付に起因する競合
  • 雇用情報のバリデーションエラー
  • PAN/メールアドレスの重複
  • CTC の設定ミス など



Zoho Payroll のよくあるエラーと解決方法:

13. 入社日がすでに給与処理済みの支給期間に含まれています。入社日は、指定された日付以降である必要があります


原因: このエラーは、すでに給与処理が完了している月に入社日(DOJ)を設定した従業員を追加しようとした場合に発生します。
解決方法:
  • 該当月の給与処理が完了する前に従業員を追加しているか確認します。
  • すでに処理済みの場合は、給与処理を取り消すか、次の支給期間以降の日付を入社日に設定してください。


14. この従業員は Zoho People から同期されています。退職処理を開始するには、Zoho People 上で退職済みに設定してください。

原因: 従業員が Zoho People から同期されているにもかかわらず、Zoho Payroll 上で直接退職処理を行おうとした場合に発生します。
解決方法:

以下の手順に従ってください。
  1. Zoho People で退職情報を更新する
    • 退職日(DOE)と従業員ステータスを更新します。
    • DOE が給与処理済みの月になっていないことを確認します。

  2. 即時同期を実行する
    • 次のパスで移動します:
      設定 → Zoho アプリ → People → 即時同期
    • 表示される同期エラーを解消します。

  3. Zoho Payroll で退職処理を完了する
    • [ホーム] → [To-Do] セクションに移動します。
    • 通常の給与処理を実行する前に退職処理を完了します。
メモ: その月の給与がすでに処理済みの場合は、回避策として、当月内の日付を DOE に設定して従業員を退職させてください。


15. Employment Type: 項目の値が、当社でサポートしているデータ型と一致しません。

原因: Zoho People の Employment Type の値が、Zoho Payroll でサポートされている事前定義値と一致していません。

解決方法:
  • 値が大文字・小文字を含めて完全一致していることを確認します。
  • 独自の値や余分なスペースを使用しないでください。
  • 必要に応じて初期値を設定し、再度同期を実行します。



16. グラチュイティ額を、給与シート上で月次の按分ベースで表示し、従業員ごとのグラチュイティ累積額を月次で表示する列を作成したい。

制限事項: Zoho Payroll では、月次のグラチュイティ累積額の表示を標準ではサポートしていません。

回避策:
  1. [給与コンポーネント] で福利厚生コンポーネントを作成します。
  2. 月次のグラチュイティ額を手動で計算します。
  3. 従業員プロフィールで事業主負担として追加します。
これにより、金額が月次で反映され、Zoho Books にも同期されます。



17. 有効な Routing Number/SWIFT コードを入力してください。

原因: Routing Number の形式が無効、またはカスタム項目のバリデーションルールが不適切です。

解決方法:
  • 次のパスでカスタム項目のバリデーションを確認します:
    設定 → 環境設定 → 従業員
  • Routing Number が有効な形式になっていることを確認します。


18. 2025年6月10日付で昇進し、給与が増額された従業員がいます。Zoho People と Zoho Payroll の両方でどのように更新すれば、正確に給与が計算されますか?Payroll では「給与改定月」のみを指定する形式で、日付を入力できません。

原因: Zoho Payroll は現時点では月単位の給与改定のみをサポートしています。

解決方法:
  • 日付ベースの給与改定(早期アクセス)を有効化します。
  • サポートチームに組織 ID を共有し、バックエンド側で機能を有効化してもらいます。


19. 従業員はすでに xyxyxyxx@zzz.com で登録されています。

原因: 同じメールアドレスが Zoho Expense など、他の Zoho サービスですでに使用されています。

解決方法:
  1. Zoho Expense から該当メールアドレスを削除します。
  2. Zoho Payroll に従業員を追加します。
  3. 各サービス間で反映されるよう、同期を実行します。


20. 無効な給与レートが指定されています [給与改定のインポート時にエラー]

原因: 給与改定の種類(数値ベースかパーセンテージベースか)が設定と一致していません。

解決方法:
  • 給与改定が金額(Number)ベースで行われる設定になっていることを確認します。
  • それに合わせてインポートファイルを修正します。


21. 事業所がフリーゾーンにある場合は、勤務先所在地を更新する必要があります - [通常給与] の [保留中のタスク] に表示されます。

原因: 該当する勤務地について、給与計算上フリーゾーン区分の設定が必要です。

解決方法:
  • 次のパスで移動します:
    設定 → 勤務地
  • 対象の勤務地を選択し、[フリーゾーンとしてマーク]を有効にします。


22. この従業員のメールアドレスは Zoho アカウントで利用できなくなっています。そのため、ポータルにアクセスできません。ポータルアクセスを取り消し、有効なメールアドレスに更新してください。



原因: 従業員に紐づいているメールアドレスが無効化されているか、削除されています。

解決方法:
  • Zoho Payroll でポータルアクセスを取り消す
  • 従業員のメールアドレスを更新する
  • 該当する場合は退職手続きを進める



23.
この PAN はすでに存在します。各従業員に登録する PAN は一意になるようにしてください。



原因: 同じ PAN が複数の従業員プロファイルで使用されています。

解決方法:
  • 退職済み/非アクティブな従業員プロファイルから PAN を削除する
  • すべてのレコードで PAN が重複しないことを確認する



24. システムが算出した固定手当は 0 未満にはできません。給与情報を確認し、有効な値を入力してください。

 

原因: 会社負担分(EPF/ESI)が、CTC 内の固定手当額を上回っています。

解決方法:
  • 給与構成要素を再設計する
  • 固定手当で会社負担分をカバーできるようにする
例: EPF 負担額 = ₹1,800 の場合 → 固定手当 ≥ ₹1,800



25. このメールアドレスは別のユーザーに関連付けられているため、更新できません:


原因:
メールアドレスが Zoho Payroll のユーザー/管理者として紐づいています。

解決方法:
  1. ユーザー/管理者一覧から該当メールアドレスを削除する
  2. 従業員のメールアドレスを更新する
  3. 必要に応じて、再度ユーザー/管理者として追加する


まとめ

これで、Zoho Payroll エラー処理および解決マニュアルのパート 2は完了です。

上記の解決方法に従うことで、給与関連のエラーの多くを効率的にトラブルシュートし、Zoho Payroll およびその連携機能全体でスムーズな処理を維持できます。



カスタムソリューション作成者: Balaji | Zoho Partner Support

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