SCORMファイルのトラブルシューティングガイド

SCORMファイルのトラブルシューティングガイド

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SCORMファイルのインポート時によく発生する問題のトラブルシューティングについては、本記事をご参照ください。

1. ファイルのインポートに失敗しました

問題点:

インポートしようとしたSCORMファイルをアップロードできませんでした。

原因:

imsmanifest.xmlファイルが存在しない、または郵便番号ファイルのルートディレクトリに配置されていません。Zoho参照では、このマニフェストファイルが必要となり、タブの読み込み方法を判断します。また、フォルダー自体を郵便番号した場合にもこのエラーが発生することがあります。

解決方法:

  • imsmanifest.xmlファイルが圧縮パッケージのルートに配置されていることを確認してください。

  • SCORMファイルを含むフォルダーをそのまま郵便番号せず、フォルダー内の内容のみを直接郵便番号してください。

2. 無効なSCORMバージョン

問題点:

SCORMファイルが無効なため、インポートできません。

原因:

Zoho参照がサポートしているのはSCORM 1.2およびSCORM 2004(第3版・第4版)のみです。他のバージョンで作成されたタブをアップロードすると、読み込み中エラーが発生します。

解決方法:

  • SCORMオーサリングツールに戻ってください。

  • タブをSCORM 1.2またはSCORM 2004(第3版または第4版)形式でエクスポートまたは再パッケージしてください。

3. SCORM開始時に白いページが表示される

問題点:

SCORMタブを起動すると、画面が真っ白のまま表示されます。

原因:

SCORMパッケージが許可されていない外部ソースからコンテンツを読み込もうとする場合があります。現代のブラウザでは、特にサードパーティCookieが無効になっている場合、クロスオリジンリクエストがブロックされます。これにより、白い画面が表示されることがあります。

解決方法:

  • ユーザーにブラウザの設定でサードパーティCookieを有効にするよう依頼してください。

  • SCORMオーサリングツールを最新バージョンに更新し、現代のブラウザのセキュリティ基準に準拠するようパッケージを再公開してください。

サードパーティCookieの管理について詳しくはこちらをご参照ください。

4. アクセスが拒否されました:エラー403

問題点:

SCORMファイルの起動時にアクセスが拒否されます。

原因:

一部の設定でコンテンツの読み込みに必要なサードパーティCookieがブロックされている場合、この問題が発生します。

解決方法:

  • ユーザーにブラウザの設定でサードパーティCookieを有効にするよう案内してください。

サードパーティCookieの管理について詳しくはこちらをご参照ください。

5. 起動が遅い

問題:

SCORMタブの読み込みが遅い、または使用中に遅延が発生します。

原因:

この問題は、古いまたは互換性のないブラウザがコンテンツを正しく読み込めない、または実行できない場合に発生します。

解決方法:

  • ユーザーが最新のブラウザ(例:Chrome、Firefox、Edge)でタブにアクセスしていることを確認してください。

  • 動作が遅い場合は、ユーザーにキャッシュのクリアやシークレットモードの利用を推奨してください

6. カスタムドメイン利用時のSCORMアップロード・ダウンロードエラー

問題:

Zoho参照でカスタムドメインを利用している際、SCORMのアップロードやダウンロードが失敗します。他の機能は正常に動作する場合があります。

原因:

カスタムドメインを利用している場合、一部のSCORM処理はサードパーティCookieに依存しています。ブラウザでこれらのCookieがブロックされていると、アップロードやダウンロードができません。

解決方法:

  • ユーザーにサードパーティCookieを有効にするようブラウザ設定を案内してください。

SCORMアップロード・ダウンロードエラーについて詳しくはこちらをご参照ください。